Missing data in US Carbon Watch

Incident Report for Kayrros

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 17:05 CEST

Investigating

We are currently investigating missing data for 2025/08/14
Posted Aug 18, 2025 - 16:48 CEST
This incident affected: Carbon Watch (Website dashboards, Emails distribution, API).