Methane Watch missing data

Incident Report for Kayrros

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 11:39 CEST

Investigating

We are investigating missing historic Sentinel-5P detections
Posted Jun 05, 2025 - 11:16 CEST
This incident affected: Methane Watch (Website dashboards).