Missing wind data on Methane Watch

Incident Report for Kayrros

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 09:44 CEST

Investigating

We are currently investigating missing wind data
Posted Oct 02, 2025 - 16:26 CEST
This incident affected: Methane Watch (Website dashboards).