Methane Watch missing data
Incident Report for Kayrros
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 11:20 CET
Investigating
We are investigating changes in naming conventions of Sentinel-5P products on CDSE leading to a disruption of Methane Watch live S5P data
Posted Nov 25, 2024 - 14:08 CET
This incident affected: Methane Watch (Website dashboards).