On-Road missing latest US data

Incident Report for Kayrros

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 15:17 CEST

Identified

One of our data providers is experiencing some delays
Posted Apr 10, 2026 - 14:29 CEST
This incident affected: On-road demand (Website dashboards, Emails distribution).