Inaccurate latest fuel emissions data

Incident Report for Kayrros

Identified

The issue comes from a public dataset provider. We are currently working on a fix
Posted Dec 01, 2025 - 17:18 CET

Investigating

We are currently investigating this issue.
Posted Dec 01, 2025 - 14:48 CET
This incident affects: US Carbon Watch (Website dashboards, API).